× Welcome to the Kunena forum!

Tell us and our members who you are, what you like and why you became a member of this site.
We welcome all new members and hope to see you around a lot!

Trouble connecting to M2RET with SavvyCAN

  • rjsmith
  • rjsmith's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
3 months 1 week ago #163 by rjsmith
rjsmith created the topic: Trouble connecting to M2RET with SavvyCAN
I'm using SavvyCAN for the first time and trying to stream messages from my M2, but I seem to be having a problem similar to this post .

I can see messages and change settings just fine from the Arduino Serial Monitor and CoolTerm, but when I try to create a connection in SavvyCAN nothing seems to happen. It adds three busses to the connections list, but they all show as Not Connected, and nothing is displayed in the Device console in SavvyCAN. (when I remove the connections though '~GVRetSerial()' is printed).

It looks like a bug in SavvyCAN because it doesn't even seem to by trying to connect. I'm using SavvyCAN Version 186 for macOS downloaded from this website.

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago #167 by collink
collink replied the topic: Trouble connecting to M2RET with SavvyCAN
I'm told there's an issue on OSX that might be what you are experiencing. The GVRET driver now supports TCP/IP connections as well. And, it figures out whether you used Serial or TCP/IP by looking for a . character. On OSX serial ports apparently tend to have a . in their name and this messes it up. Someone found that issue and it will be corrected soon.

Please Log in or Create an account to join the conversation.

More
3 months 4 days ago #170 by collink
collink replied the topic: Trouble connecting to M2RET with SavvyCAN
This should be fixed now. Commit 1c612a8c4ac724a86c5408681376e6ec279970c1 in the master branch.

Please Log in or Create an account to join the conversation.

Time to create page: 0.054 seconds
Powered by Kunena Forum