× Welcome to the Kunena forum!

Tell us and our members who you are, what you like and why you became a member of this site.
We welcome all new members and hope to see you around a lot!

Unable to play back recorded files

  • atmegatron
  • atmegatron's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
2 years 4 months ago #297 by atmegatron
Unable to play back recorded files was created by atmegatron
Hello all!

Firstly, thank you for the hard work that went into this project! It is a great tool.

I am having an issue and I am hoping someone can shine some light on it. Maybe I am misunderstanding a feature, but the playback feature will playback files onto the CAN bus that I recorded in SavvyCAN, correct?

I have two Macchina m2's, and while both can read CAN bus traffic just fine with SavvyCAN, when I use the playback feature, they output a ~20Khz sqaure(ish) wave:

Bus+ output:



Bus- ouput:



This ~20Khz wave continues even after playback has stopped, and after SavvyCAN has been closed. I am running V197 of SavvyCAN and the precompiled M2RET Flash from the Macchina website. I have tried the latest versions form the SavvyCAN website, same issue.

Am I being a pinecone? What am I doing wrong, or am I misunderstanding the playback feature?

Thank you for your time!

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #298 by collink
Replied by collink on topic Unable to play back recorded files
You should be able to playback captures and have it work. The combination of software and hardware you're using should work that way. One thing I might ask is what you have hooked up while doing your test playback. What is connected to the CAN bus when you do this playback? If it's just the oscilloscope then you will get funny results. The M2 itself is not terminated. CAN requires both ends of the bus be terminated. If you have zero termination points then it won't output a good signal at all. Connecting two M2's together with nothing else also doesn't work for the same reason. But, if this test was done with the M2 connected to a car then something is very wrong.

Please Log in or Create an account to join the conversation.

  • atmegatron
  • atmegatron's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
2 years 4 months ago #300 by atmegatron
Replied by atmegatron on topic Unable to play back recorded files
You nailed it! I assumed the device I had it connected to was terminated, and it was not. Threw a 130R (couldn't find a 120R) in parallel, and bam! Lol.

Thank you for your help. I tried to find a donation link on the homepage, but didn't see one. Again, I appreciate your work on this project.

Please Log in or Create an account to join the conversation.

Time to create page: 0.059 seconds
Powered by Kunena Forum